Plesk PHP-FPM server reached max_children

Für den PHP-FPM Prozess wurde auf dem Server aus Sicherheitsgründen ein Limit gesetzt. Sprich es können nur eine maximale Anzahl von gleichzeitigen Prozessen gestartet werden um den Server nicht zu überlasten. Gründe für das Erreichen dieser Grenze können folgende sein:

  • Eine Menge gleichzeitiger Seitenaufrufe
  • PHP Skripte die langsam ausgeführt werden (sei es durch schlecht programmierte Skripte oder durch umfangreiche Aufgaben des Skripts)

Wenn also in den Logfiles auf dem Server unter

folgende Fehlermeldung auftaucht:

Dann müsste die Anzahl gleichzeitiger Prozesse in der folgenden Datei angepasst werden (Eventuell muss diese Datei auch neu angelegt werden):

Danach zuerst die PHP-Settings von Plesk neu einlesen lassen mit:

und nun den PHP-FPM Service neu starten mit:

xx  ist dabei zu ersetzen mit der jeweiligen PHP-Version

Postfix startet nicht automatisch nach Server-Reboot

Symptoms

  • Postfix startet nicht automatiusch nach einem Systemstart.
  • Postfix kann manuell und über die Plesk-Oberfläche gestartet werden.
  • Postfix presents in /etc/init.d/ and /etc/rc.d/init.d/
  • The runlevel entries for postfix are deleted after plesk repair mail execution:

Cause

This is bug with ID PPP-27031 which is planned to be fixed in future Plesk updates.

Resolution

Run the following command to add Postfix to the boot sequence:

Quelle: https://support.plesk.com/hc/en-us/articles/115000066385-Postfix-does-not-start-automatically-after-system-reboot

Wie ist der Ablauf bei der Bestellung eines SSL-Zertifikates?

Sie generieren ein sogenanntes Certificate Signing Request (zum Beispiel in Ihrer Plesk Oberfläche/Schlüssellänge 2048. Kleinere Schlüssellängen werden nicht unterstützt.)

  • Sie bestellen über unser Kundencenter ein SSL Zertifikat und geben bei der Bestellung gleich ihr Certificate Signing Request an. 
  • Zusätzlich müssen Sie dieses PDF-Formular ausfüllen und per E-Mail an vertrieb@cmo.de senden:
    • Sofern Sie eine Privatperson sind:
      • Kopie des Personalausweises beide Seiten (Name und Adresse auf dem Personalausweis muss identisch mit dem Namen und Adresse sein welche bei der Domänregistrierungsstelle für die Domäne beim Domaininhaber hinterlegt wurden. Eventuell zuvor Update bei der Domain fahren)
      • Digital Actionform (siehe Anhang zu diesem FAQ-Beitrag) vom Domaininhaber unterschrieben
    •  Sofern Sie eine Firma sind:
      • Kopie der Gewerbeanmeldung (Name und Adresse auf dem Gewerbeanmeldung muss identisch mit dem Namen und Adresse sein welche bei der Domänregistrierungsstelle für die Domäne beim Domaininhaber hinterlegt wurden. Eventuell zuvor Update bei der Domain fahren
      • Kopie des Handelsregisterauszuges (falls vorhanden. Name und Adresse auf dem Handelsregisterauszug muss identisch mit dem Namen und Adresse sein welche bei der Domänregistrierungsstelle für die Domäne beim Domaininhaber hinterlegt wurden. Eventuell zuvor Update bei der Domain fahren)
      • Kopie des Personalausweises (beide Seiten) des Geschäftsführers
      • Digital Actionform (siehe Anhang zu diesem FAQ-Beitrag) vom Geschäftsführer unterschrieben.
  • Nach Erhalt der Zahlung beantragt der CMO Support das Zertifikat und sendet dieses nach Zuteilung an ihre E-Mail-Adresse

 

 

Übermitteln der Installationsmedien für die Server

Übermitteln der Installationsmedien für die Server:

Um eine CD zur Installation bereitstellen zu können benötigen Sie lediglich folgendes Programm: MagicISO Virtual CD/DVD-ROM, dieses erhalten Sie unter folgendem Link: http://www.magiciso.com/tutorials/miso-magicdisc-overview.htm. Laden Sie hier die Version entsprechend ihrem Betriebssystem herunter und installieren Sie dieses. Bei der Installation kann es vorkommen, dass Sie einen Warnhinweis erhalten bestätigen Sie diesen mit „Treiber trotzdem installieren“.
Nach Abschluss der Installation läuft das Programm bereits. Klicken Sie in der Taskleiste mit der rechten Maustaste auf folgendes Symbol: (Siehe Anhang pic1.jpg)  es öffnet sich ein Menü. Klicken Sie in diesem Menü auf „Make CD/DVD Image“ . Es öffnet sich folgendes Fenster:

(Siehe Anhang pic2.jpg)

Wählen Sie bei Source CD/DVD-Rom ihr CD-Laufwerk aus, welches die CD beinhält welche Sie installieren möchten. Bei „Output File“ wählen Sie den Pfad und Dateinamen aus wo die Kopie der CD auf Ihrem PC gespeichert werden  soll. Als „Output format“ wählen Sie bitte „*.UIF“ Den Rest lassen Sie bitte unverändert und klicken auf OK.
Nach der Fertigstellung des UIFs kopieren Sie dieses über die per Remotedesktop eingebundenen Netzlaufwerke auf Ihren Terminalserver auf den Desktop und teilen uns den Benutzernamen und den Dateinamen mit.

Wie können unter Exchange 2010 E-Mails mit einem bestimmten Betreff gelöscht werden?

Wichtig ist dass auf dem Server folgende Rollen:

  • Postfachsuche
  • Postfachimport/-export

dem Benutzer Administrator zugewiesen sind. Dies geht über die Verwaltungsoberfläche unter http://servername/ecp.

Die Bearbeitung erfolgt dann über die Exchange Verwaltungsshell per Administratoraccount.

Mit dem Befehl:

Search-Mailbox -Identity „Vor- Zuname“ -SearchQuery ‚Thema:“Suchtext“‚ -TargetMailbox Administrator -TargetFolder „SearchLogs“ -LogOnly -LogLevel Full

Kann geprüft werden welche E-Mails gefunden werden.

Mit dem Befehl:

Search-Mailbox -Identity „Vor- Zuname“ -SearchQuery ‚Thema:“Suchtext“‚ -DeleteContent

Können dann die E-Mails gelöscht werden.

Rechnungseinspruch

Einwendungen gegen Rechnungen müssen schriftlich innerhalb von 8 Wochen nach Rechnungsdatum bei CMO Internet Dienstleistungen GmbH, Kaiserstraße 57/1, 72766 Reutlingen eingegangen sein. Nach dieser Frist gelten Abrechnungen als genehmigt.

Panda 2013 Installation und Aktivierung unter Windows 8

Panda lässt sich unter Umständen unter Windows 8 nicht aktivieren, da sich der Aktiviation Wizard nicht direkt über das Panda Panel starten lässt.

Dieser lässt sich aber über einen kleinen Umweg dennoch starten:

Navigieren Sie über ihren Explorer in das Panda-Verzeichnis (Beispiel: C:\Programme\Panda)

Hier suchen Sie nach dem Activation Wizard: PSROL.exe  und führen diesen aus.

Nun lässt sich Panda wie gewohnt aktivieren.

Wie aktiviere ich ein deaktiviertes Add-In in Microsoft Outlook?

Rufen Sie die Add-In Verwaltung auf. Dies geht in Outlook 2013 wie folgt.

  • Klicken Sie auf Datei
  • Klicken Sie auf Optionen
  • Klicken Sie auf Add-Ins

Prüfen Sie ob das Add-In unter deaktivierte oder inaktive Add-Ins aufgeführt ist.

Wenn das Add-In unter deaktivierte Add-Ins aufgelistet ist führen Sie folgendes durch:

  • Bei Verwalten „Deaktive Elemente“ auswählen
  • Auf „Gehe zu“ klicken
  • Das entsprechende Add-In in der Liste markieren
  • Aktivieren klicken

Sollt Ihr Add-In nun unter inaktive Add-Ins gelistet sein oder von vornherein unter inaktive Add-Ins gelistet sein führen Sie folgendes durch:

  • Bei Verwalten „COM-Add-Ins“ auswählen
  • Auf „Gehe zu“ klicken
  • Beim entsprechenden Add-In in der Liste das Häkchen setzen
  • Auf „Okay“ klicken

Das Add-In ist nun in Outlook nutzbar.

Sollte beim Neustart das Add-In in Outlook wieder nicht verfügbar sein und in der Add-In Verwaltung wieder im Bereich inaktiv stehen bitte noch folgendes durchführen:

  • Starten Sie den Registrierungseditor in einer Eingabeaufforderung mit regedit.exe
  • Wählen Sie den Schlüssel HKEY_CURRENT_USER\Software\Microsoft\Office\Outlook\Addins\
  • Wählen Sie dort den Schlüssel des betreffenden Add-Ins aus
  • Dort dann den D-Word Wert LoadBehavior auf 3 statt 1 setzen
  • Schließen sie den Registrierungseditor

Jetzt wird Ihr Outlook Add-In dauerhaft beim Start geladen.

Änderung Speicherort „Gesendete Objekte“ eines Sammelpostfaches in Exchange

Wenn Sie für ein Benutzerpostfach oder ein freigegebenes Postfach die Berechtigung „Senden Als“ oder „Vollzugriff“ haben und Sie über Exchange 2013 eine E-Mail mit der E-Mail Adresse dieses Postfaches versenden, wird standardmäßig die gesendete E-Mail in ihrem eigenen Postfach unter „Gesendete Objekte“ abgespeichert.

Sofern Sie nun möchten das zusätzlich auch eine Kopie der gesendeten E-Mail im Ordner „Gesendete Objekte“ des Postfaches der gewählten Absender E-Mail Adresse landet müssen Sie folgendes durchführen:

  1. Öffnen Sie auf dem Exchange Server die Exchange Management Shell
  2. Prüfen Sie mit dem Befehl Set-Mailbox -Identity E-Mail-Adresse -Type Shared (ersetzen Sie E-Mail-Adresse mit der E-Mail Adresse des gewünschten Postfachs) ob die Mailbox bereits vom Typ Shared ist. Wenn ja erhalten Sie eine Warnung dass die Mailbox schon vom Typ Shared ist. Wenn diese noch vom Typ Benutzer ist, konvertiert er die Mailbox in den Typ Shared. Dabei gehen keine Einstellungen und E-Mails verloren.
  3. Konfigurieren Sie mit dem Befehl Set-mailbox -identity E-Mail-Adresse -MessageCopyForSentAsEnabled $true -MessageCopyForSendOnBehalfEnabled $true das Postfach so um, dass dieses eine Kopie der in seinem Namen gesendete E-Mails erhält.  Dieser Befehl funktioniert nur bei freigegebenen Postfächern (Type Shared)

RPM Datenbank neu erstellen

Wenn beim Aufruf von yum die Fehlermeldung

rpmdb: Program version 4.3 doesn’t match environment version

kommt dann ist die RPM Datenbank nicht mehr in Ordnung. Diese kann mit den Befehlen:

# rm -f /var/lib/rpm/__db.*

# rpm –rebuilddb

neu erstellt werden.